Apache Zeppelin Issues - Python Errors


Question


I have an issue with Apache Zeppelin.

When I run a new python notebook and try to execute a command like import dask it results in the following errors:

Traceback (most recent call last):
  File "/tmp/1599314081091-0/zeppelin_python.py", line 162, in <module>
    code = compile(mod, '<stdin>', 'exec')
TypeError: required field "type_ignores" missing from Module. 

This looks like a setup issue, but I'm not sure where to configure.


Answer 1:


I got the same error with zeppelin-0.9.0-preview2. It seems Zeppelin is not compatible with python 3.8. Downgrading python to 3.7 fixed the issue. This the issue reported in CPython https://bugs.python.org/issue35894. Looks like we have to wait for Zeppelin to add a fix by checking the python version.



来源:https://stackoverflow.com/questions/63754720/apache-zeppelin-issues-python-errors


码神部落- 版权声明 1、本主题所有言论和图片纯属会员个人意见,与码神部落立场无关。
2、本站所有主题由该帖子作者发表,该帖子作者半岛情歌码神部落享有帖子相关版权。
3、码神部落管理员和版主有权不事先通知发贴者而删除本文。
4、其他单位或个人使用、转载或引用本文时必须同时征得该帖子作者半岛情歌码神部落的同意。
5、帖子作者须承担一切因本文发表而直接或间接导致的民事或刑事法律责任。
6、本帖部分内容转载自其它媒体,但并不代表本站赞同其观点和对其真实性负责。
7、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意。

最新回复 (0)
    • 码神部落
      2
        立即登录 立即注册 GitHub登录
返回
发新帖
作者最近主题: