Failed to attach the USB device SEGGER J-Link [0100] to the virtual machine WINDOWS 7 [closed]


Question


I am running Windows 7 inside Mac OS X with VirtualBox, I used a BLE inside W7 without any problem. Then I used the BLE USB in the Mac, and when I try to use it again in the W& I got this message:

Failed to attach the USB device SEGGER J-Link [0100] to the virtual machine WINDOWS 7.
USB Device 'SEGGER J-Link’ with UUID {} is in use by someone else

I unplugged the USB, restart the Mac, start W7, but I can't attach it again to the W7


Answer 1:


I figured it out. You are supposed to:

  1. Shutdown the guest
  2. Plug in the device, let the host grab it
  3. In the host, go to virtual box, and edit the configuration for the guest. In the "Ports" tab, go to USB and add a filter to include the plugged in device
  4. Unplug the device
  5. Start the guest OS
  6. When the guest os is running, plug in the device.

Virtual box will grab the usb device and make it available for the guest. The guest will then go on and try to identify and configure the device.

Done.




Answer 2:


The solution for me was to install the Oracle VM VirtualBox Extension Pack. I had to update virtual box to the latest version then download the latest version of the extension pack.

Then, on the USB tab of the virtual machine settings, I set 'Enable USB Controller' and 'USB 2.0 (EHCI) Controller'. Before it was set to USB 1.1 (OHCI) Controller which did not work. Then just add a USB filter for the composite device and when I started up the machine again everything worked.

USB Page Image




Answer 3:


I am using an nRF51-DK Embedded Development Kit from Nordic Semiconductor which has a Segger JLink embedded on the board. I was having problems getting it to detect on the Mac OS X, Running VirtualBox/Windows 7.

I tried adding a filter under Ports->USB in the Device Image Settings. The device was coming up as a composite device under USB Devices in Windows 7 Device Manager.

Then I removed the filter, installed the Segger/JLink Driver for Mac, ensured that Mac is picking up the device by running the JLinkExe Utility. I then proceeded to add a filter in the Ports->USB under the device image and voila! - Windows 7 Picked up Segger/JLink over VirtualBox.

As a side note, I had also installed the Oracle VM Extension Pack for my VirtualBox version from www.virtualbox.org




Answer 4:


J-Link debug probe of version 9.3 works perfectly with the VirtualBox(VB) with USB1.1 (without an extension pack). Once I started using the newer J-Link debug probe of version 10.1, the jlink device was not recognized in the VB because the jlink device driver failed to install. This problem was solved with the extension pack for virtualbox. But the extension pack needs a license for long term use so be aware.



来源:https://stackoverflow.com/questions/26474687/failed-to-attach-the-usb-device-segger-j-link-0100-to-the-virtual-machine-wind


码神部落- 版权声明 1、本主题所有言论和图片纯属会员个人意见,与码神部落立场无关。
2、本站所有主题由该帖子作者发表,该帖子作者爷万人跪拜码神部落享有帖子相关版权。
3、码神部落管理员和版主有权不事先通知发贴者而删除本文。
4、其他单位或个人使用、转载或引用本文时必须同时征得该帖子作者爷万人跪拜码神部落的同意。
5、帖子作者须承担一切因本文发表而直接或间接导致的民事或刑事法律责任。
6、本帖部分内容转载自其它媒体,但并不代表本站赞同其观点和对其真实性负责。
7、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意。

最新回复 (0)
    • 码神部落
      2
        立即登录 立即注册 GitHub登录
返回
发新帖
作者最近主题: